Contact ProExe
Live Chat
Knowledgebase: Installation
What is required from my computer to be able to use F-Secure Internet Security 2007?
Posted by James Robshaw on 29 March 2007 12:24 PM

To be able to use F-Secure Internet Security 2007 your computer must meet the following minimum requirements to install and run the product:
F-Secure

Processor:

Intel Pentium III 600Mhz or higher (1Ghz recommended)

Operating System:

Windows XP Home Edition (SP2 recommended)

Windows XP Professional Edition (SP2 recommended)

Windows 2000 Workstation SP4 (Update Rollup 1 recommended)

Memory:

256MB of RAM (512MB recommended)

Disk Space:

500MB free hard disk space (800MB recommended)

Display:

Minimum 256 colors (16bit or more recommended)

Internet Connection:

An Internet connection is required to validate your subscription and receive updates

Browser:

Internet Explorer 5.0 or newer is required (6.0 or 7.0 recommended)

(439 vote(s))
This article was helpful
This article was not helpful

Comments (0)