Contact ProExe
Live Chat
Knowledgebase: Before Installation
Which operating systems does the product support?
Posted by James Robshaw on 29 March 2007 12:00 PM

Home and Small Office Users.

F-Secure Internet Security 2007 currently supports the following operating systems: Win 2000, XP & Vista.

However, the product does not support the server versions of the above operating systems.

(239 vote(s))
This article was helpful
This article was not helpful

Comments (0)